<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.oxymoronical.com/wp/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/js/html5.js"></script>
	<![endif]-->
	<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Please watch your character encodings &#8211; Oxymoronical</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Oxymoronical &raquo; Feed" href="https://www.oxymoronical.com/blog/feed" />
<link rel="alternate" type="application/rss+xml" title="Oxymoronical &raquo; Comments Feed" href="https://www.oxymoronical.com/blog/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Oxymoronical &raquo; Please watch your character encodings Comments Feed" href="https://www.oxymoronical.com/blog/2019/07/Please-watch-your-character-encodings/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.oxymoronical.com\/wp\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentyfifteen-jetpack-css'  href='https://www.oxymoronical.com/wp/wp-content/plugins/jetpack/modules/theme-tools/compat/twentyfifteen.css?ver=7.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.oxymoronical.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://www.oxymoronical.com/wp/wp-includes/css/dist/block-library/theme.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%3A400italic%2C700italic%2C400%2C700%7CNoto+Serif%3A400italic%2C700italic%2C400%2C700%7CInconsolata%3A400%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://www.oxymoronical.com/wp/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-style-css'  href='https://www.oxymoronical.com/wp/wp-content/themes/oxymoronical/style.css?ver=5.2.2' type='text/css' media='all' />
<style id='twentyfifteen-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='twentyfifteen-block-style-css'  href='https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/css/blocks.css?ver=20181230' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfifteen-ie-css'  href='https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/css/ie.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentyfifteen-ie7-css'  href='https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/css/ie7.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.oxymoronical.com/wp/wp-content/plugins/jetpack/css/jetpack.css?ver=7.5.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.oxymoronical.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.oxymoronical.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.oxymoronical.com/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Bridging an internal LAN to a server&#8217;s Docker containers over a VPN' href='https://www.oxymoronical.com/blog/2019/03/Bridging-an-internal-LAN-to-a-servers-Docker-containers-over-a-VPN' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel="canonical" href="https://www.oxymoronical.com/blog/2019/07/Please-watch-your-character-encodings" />
<link rel='shortlink' href='https://www.oxymoronical.com/?p=1942' />
<link rel="alternate" type="application/json+oembed" href="https://www.oxymoronical.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.oxymoronical.com%2Fblog%2F2019%2F07%2FPlease-watch-your-character-encodings" />
<link rel="alternate" type="text/xml+oembed" href="https://www.oxymoronical.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.oxymoronical.com%2Fblog%2F2019%2F07%2FPlease-watch-your-character-encodings&#038;format=xml" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d0e4f4; }
</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Please watch your character encodings" />
<meta property="og:url" content="https://www.oxymoronical.com/blog/2019/07/Please-watch-your-character-encodings" />
<meta property="og:description" content="I started writing this as a newsgroup post for one of Mozilla&#8217;s mailing lists, but it turned out to be too long and since this part was mainly aimed at folks who either didn&#8217;t know abou…" />
<meta property="article:published_time" content="2019-07-10T20:38:01+00:00" />
<meta property="article:modified_time" content="2019-07-10T20:44:34+00:00" />
<meta property="og:site_name" content="Oxymoronical" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@EnglishMossop" />
<meta name="twitter:text:title" content="Please watch your character encodings" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="post-template-default single single-post postid-1942 single-format-standard custom-background wp-embed-responsive">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="sidebar" class="sidebar">
		<header id="masthead" class="site-header" role="banner">
			<div class="site-branding">
										<p class="site-title"><a href="https://www.oxymoronical.com/" rel="home">Oxymoronical</a></p>
												<p class="site-description">The humble opinions of Dave Townsend</p>
										<button class="secondary-toggle">Menu and widgets</button>
			</div><!-- .site-branding -->
		</header><!-- .site-header -->

			<div id="secondary" class="secondary">

					<nav id="site-navigation" class="main-navigation" role="navigation">
							</nav><!-- .main-navigation -->
		
		
					<div id="widget-area" class="widget-area" role="complementary">
				<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://www.oxymoronical.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit screen-reader-text" value="Search" />
			</form></aside><aside id="tag_cloud-2" class="widget widget_tag_cloud"><h2 class="widget-title">Tags</h2><div class="tagcloud"><ul class='wp-tag-cloud' role='list'>
	<li><a href="https://www.oxymoronical.com/blog/tag/addons" class="tag-cloud-link tag-link-28 tag-link-position-1" style="font-size: 19.873417721519pt;" aria-label="addons (65 items)">addons</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/amo" class="tag-cloud-link tag-link-41 tag-link-position-2" style="font-size: 9.0632911392405pt;" aria-label="amo (3 items)">amo</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/bugs" class="tag-cloud-link tag-link-14 tag-link-position-3" style="font-size: 11.278481012658pt;" aria-label="bugs (6 items)">bugs</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/camera" class="tag-cloud-link tag-link-81 tag-link-position-4" style="font-size: 9.9493670886076pt;" aria-label="camera (4 items)">camera</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/code" class="tag-cloud-link tag-link-13 tag-link-position-5" style="font-size: 17.215189873418pt;" aria-label="code (32 items)">code</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/commercial" class="tag-cloud-link tag-link-39 tag-link-position-6" style="font-size: 8pt;" aria-label="commercial (2 items)">commercial</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/conference" class="tag-cloud-link tag-link-37 tag-link-position-7" style="font-size: 12.164556962025pt;" aria-label="conference (8 items)">conference</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/development" class="tag-cloud-link tag-link-23 tag-link-position-8" style="font-size: 21.113924050633pt;" aria-label="development (91 items)">development</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/extension-manager" class="tag-cloud-link tag-link-34 tag-link-position-9" style="font-size: 18.189873417722pt;" aria-label="extension manager (42 items)">extension manager</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/extensions" class="tag-cloud-link tag-link-145 tag-link-position-10" style="font-size: 12.164556962025pt;" aria-label="extensions (8 items)">extensions</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/firefox" class="tag-cloud-link tag-link-65 tag-link-position-11" style="font-size: 22pt;" aria-label="firefox (114 items)">firefox</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/friends" class="tag-cloud-link tag-link-147 tag-link-position-12" style="font-size: 9.0632911392405pt;" aria-label="friends (3 items)">friends</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/help-wanted" class="tag-cloud-link tag-link-44 tag-link-position-13" style="font-size: 12.962025316456pt;" aria-label="help wanted (10 items)">help wanted</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/holiday" class="tag-cloud-link tag-link-53 tag-link-position-14" style="font-size: 9.9493670886076pt;" aria-label="holiday (4 items)">holiday</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/hosting" class="tag-cloud-link tag-link-33 tag-link-position-15" style="font-size: 10.658227848101pt;" aria-label="hosting (5 items)">hosting</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/idiots" class="tag-cloud-link tag-link-10 tag-link-position-16" style="font-size: 12.164556962025pt;" aria-label="idiots (8 items)">idiots</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/internet" class="tag-cloud-link tag-link-60 tag-link-position-17" style="font-size: 8pt;" aria-label="internet (2 items)">internet</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/jetpack" class="tag-cloud-link tag-link-69 tag-link-position-18" style="font-size: 10.658227848101pt;" aria-label="jetpack (5 items)">jetpack</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/mccoy" class="tag-cloud-link tag-link-29 tag-link-position-19" style="font-size: 8pt;" aria-label="mccoy (2 items)">mccoy</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/meme" class="tag-cloud-link tag-link-58 tag-link-position-20" style="font-size: 8pt;" aria-label="meme (2 items)">meme</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/mercurial" class="tag-cloud-link tag-link-97 tag-link-position-21" style="font-size: 12.164556962025pt;" aria-label="mercurial (8 items)">mercurial</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/mobile" class="tag-cloud-link tag-link-71 tag-link-position-22" style="font-size: 9.0632911392405pt;" aria-label="mobile (3 items)">mobile</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/module" class="tag-cloud-link tag-link-165 tag-link-position-23" style="font-size: 13.316455696203pt;" aria-label="module (11 items)">module</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/money" class="tag-cloud-link tag-link-59 tag-link-position-24" style="font-size: 8pt;" aria-label="money (2 items)">money</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/moving" class="tag-cloud-link tag-link-49 tag-link-position-25" style="font-size: 10.658227848101pt;" aria-label="moving (5 items)">moving</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/music" class="tag-cloud-link tag-link-48 tag-link-position-26" style="font-size: 8pt;" aria-label="music (2 items)">music</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/ntt" class="tag-cloud-link tag-link-15 tag-link-position-27" style="font-size: 11.278481012658pt;" aria-label="ntt (6 items)">ntt</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/palm" class="tag-cloud-link tag-link-70 tag-link-position-28" style="font-size: 9.0632911392405pt;" aria-label="palm (3 items)">palm</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/peer" class="tag-cloud-link tag-link-170 tag-link-position-29" style="font-size: 12.962025316456pt;" aria-label="peer (10 items)">peer</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/performance" class="tag-cloud-link tag-link-45 tag-link-position-30" style="font-size: 9.0632911392405pt;" aria-label="performance (3 items)">performance</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/photography" class="tag-cloud-link tag-link-148 tag-link-position-31" style="font-size: 11.721518987342pt;" aria-label="photography (7 items)">photography</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/planning" class="tag-cloud-link tag-link-38 tag-link-position-32" style="font-size: 20.670886075949pt;" aria-label="planning (80 items)">planning</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/restartless" class="tag-cloud-link tag-link-88 tag-link-position-33" style="font-size: 11.721518987342pt;" aria-label="restartless (7 items)">restartless</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/review" class="tag-cloud-link tag-link-104 tag-link-position-34" style="font-size: 10.658227848101pt;" aria-label="review (5 items)">review</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/sdk" class="tag-cloud-link tag-link-22 tag-link-position-35" style="font-size: 14.645569620253pt;" aria-label="sdk (16 items)">sdk</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/security" class="tag-cloud-link tag-link-26 tag-link-position-36" style="font-size: 9.9493670886076pt;" aria-label="security (4 items)">security</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/sleep" class="tag-cloud-link tag-link-47 tag-link-position-37" style="font-size: 8pt;" aria-label="sleep (2 items)">sleep</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/status" class="tag-cloud-link tag-link-21 tag-link-position-38" style="font-size: 20.139240506329pt;" aria-label="status (70 items)">status</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/testing" class="tag-cloud-link tag-link-31 tag-link-position-39" style="font-size: 10.658227848101pt;" aria-label="testing (5 items)">testing</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/time-management" class="tag-cloud-link tag-link-42 tag-link-position-40" style="font-size: 8pt;" aria-label="time management (2 items)">time management</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/tinderbox" class="tag-cloud-link tag-link-32 tag-link-position-41" style="font-size: 11.278481012658pt;" aria-label="tinderbox (6 items)">tinderbox</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/tools" class="tag-cloud-link tag-link-43 tag-link-position-42" style="font-size: 12.607594936709pt;" aria-label="tools (9 items)">tools</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/travel" class="tag-cloud-link tag-link-11 tag-link-position-43" style="font-size: 11.721518987342pt;" aria-label="travel (7 items)">travel</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/xulrunner" class="tag-cloud-link tag-link-30 tag-link-position-44" style="font-size: 11.278481012658pt;" aria-label="xulrunner (6 items)">xulrunner</a></li>
	<li><a href="https://www.oxymoronical.com/blog/tag/zipwriter" class="tag-cloud-link tag-link-12 tag-link-position-45" style="font-size: 9.9493670886076pt;" aria-label="zipwriter (4 items)">zipwriter</a></li>
</ul>
</div>
</aside>			</div><!-- .widget-area -->
		
	</div><!-- .secondary -->

	</div><!-- .sidebar -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-1942" class="post-1942 post type-post status-publish format-standard hentry category-mozilla category-technical tag-code tag-development tag-encoding tag-localization">
	
	<header class="entry-header">
		<h1 class="entry-title">Please watch your character encodings</h1>	</header><!-- .entry-header -->

	<div class="entry-content">
		<p>I started writing this as a newsgroup post for one of Mozilla&#8217;s mailing lists, but it turned out to be too long and since this part was mainly aimed at folks who either didn&#8217;t know about or wanted a quick refresher on character encodings I decided to blog it instead. Please let me know if there are errors in here, I am by no means an expert on this stuff either and I do get caught out sometimes!</p>
<p>Text is tricky. Unicode supports the notion of 1,114,112 distinct characters, slightly more than a byte of memory can hold. So to store a character we have to use a way of encoding its value into bytes in memory. A straightforward encoding would just use three bytes per character. But (roughly) the larger the character value the less often it is used, and memory is precious, so often variable length encodings are used. These will use fewer bytes in memory for characters earlier in the range at the cost of using a little more memory for the rarer characters. Common encodings include UTF-8 (one byte for ASCII characters, up to four bytes for other characters) and UTF-16 (two bytes for most characters, four bytes for less used ones).</p>
<p>What does this mean?</p>
<h4>It may not be possible to know the number of characters in a string purely by looking at the number of bytes of memory used.</h4>
<p>When a string is encoded with a variable length encoding the number of bytes used by a character will vary. If the string is held in a byte buffer just dividing its length by some number will not always return the number of characters in a string. Confusingly many string implementations expose a length property, that often only tells you <strong>the number of code points, not the number of characters</strong> in a string. I bet most JavaScript developers don&#8217;t know that JavaScript suffers from this:</p>
<pre>let test = "\u{1F42E}"; // This is the Unicode cow &#128046; (<a href="https://emojipedia.org/cow-face/">https://emojipedia.org/cow-face/</a>)
test.length; // This returns 2!
test.charAt(0); // This returns <span class="message-body-wrapper"><span class="message-flex-body"><span class="message-body devtools-monospace"><span class="objectBox objectBox-string">"\ud83d"</span></span></span></span>
test.charAt(1); // This returns <span class="message-body-wrapper"><span class="message-flex-body"><span class="message-body devtools-monospace"><span class="objectBox objectBox-string">"\udc2e"
test.substring(0, 1); // This returns "\ud83d"
</span></span></span></span></pre>
<p>Fun!</p>
<p>More modern versions of JavaScript do give better options, though they are probably slower than the length property (because it must decode the characters to understand the length:</p>
<pre>Array.from(test).length; // This returns 1
test.codePointAt(0).toString(16); // This returns "<span class="message-body-wrapper"><span class="message-flex-body"><span class="message-body devtools-monospace"><span class="objectBox objectBox-string">1f42e</span></span></span></span>"</pre>
<h4>When you encode a character into memory and pass it to some other code, that code needs to know the encoding so it can decode it correctly. Using the wrong encoder/decoder will lead to incorrect data.</h4>
<p>Using the wrong decoder to convert a buffer of memory into characters will often fail. Take the character &#8220;ñ&#8221;. In UTF-8 this is encoded as <code>C3 B1</code>. Decoding that as UTF-16 will result in &#8220;&#50097;&#8221;. In UTF-16 however &#8220;ñ&#8221; is encoded as <code>00 F1</code>. Trying to decode that as UTF-8 will fail as that is in invalid UTF-8 sequence.</p>
<p>Many languages thankfully use string types that have fixed encodings, in rust for example the str primitive is UTF-8 encoded. In these languages as long as you stick to the normal string types everything should just work. It isn&#8217;t uncommon though to do manipulations based on the byte representation of the characters, %-encoding a string for a URL for example, so knowing the character encoding is still important.</p>
<p>Some languages though have string types where the encoding may not be clear. In Gecko C++ code for example a very common string type in use is the nsCString. It is really just a set of bytes and has no defined encoding and no way of specifying one at the code level. The only way to know for sure what the string is encoded as is to track back to where it was created. If you&#8217;re unlucky it gets created in multiple places using different encodings!</p>
<p>Funny story. This blog posts contains a couple of the larger unicode characters. While working on the post I kept coming back to find that the character had been lost somewhere along the way and replaced with a &#8220;?&#8221;. Seems likely that there is a bug in WordPress that isn&#8217;t correctly handling character encodings. I&#8217;m not sure yet whether those characters will survive publishing this post!</p>
<h4>These problems disproportionately affect non-English speakers.</h4>
<p>Pretty much all of the characters that English speakers use (mostly the Latin alphabet) live in the ASCII character set which covers just 128 characters (some of these are control characters). The ASCII characters are very popular and though I can&#8217;t find references right now it is likely that the majority of strings used in digital communication are made up of only ASCII characters, particularly when you consider strings that humans don&#8217;t generally see. HTTP request and response headers generally only use ASCII characters for example.</p>
<p>Because of this popularity when the Unicode character set was first defined, it mapped the 128 ASCII characters to the first 128 Unicode characters. Also UTF-8 will encode those 128 characters as a single byte, any other characters get encoded as two bytes or more.</p>
<p>The upshot is that if you only ever work with ASCII characters, encoding or decoding as UTF-8 or ASCII yields identical results. Each character will only ever take up one byte in memory so the length of a string will just be the number of bytes used. An English speaking developer, and indeed many other developers may only ever develop and test with ASCII characters and so potentially become blind to the problems above and not notice that they aren&#8217;t handling non-ASCII characters correctly.</p>
<p>At Mozilla where we try hard to make Firefox work in all locales we still routinely come across bugs where non-ASCII characters haven&#8217;t been handled correctly. Quite often issues stem from a user having non-ASCII characters in their username or filesystem causing breakage if we end up decoding the path incorrectly.</p>
<p>This issue may start getting rarer. With the rise in emoji popularity developers are starting to see and test with more and more characters that encode as more than one byte. Even in UTF-16 many emoji encode to four bytes.</p>
<h4>Summary</h4>
<p>If you don&#8217;t care about non-ASCII characters then you can ignore all this. But if you care about supporting the 80% of the world that use non-ASCII characters then take care when you are doing something with strings. Make sure you are checking its length correctly when needed. If you are working with data structures that don&#8217;t have an explicit character encoding then make sure you know what encoding your data is in before doing anything with it other than passing it around.</p>
	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		<span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://www.oxymoronical.com/blog/2019/07/Please-watch-your-character-encodings" rel="bookmark"><time class="entry-date published" datetime="2019-07-10T13:38:01-07:00">July 10, 2019</time><time class="updated" datetime="2019-07-10T13:44:34-07:00">July 10, 2019</time></a></span><span class="byline"><span class="author vcard"><span class="screen-reader-text">Author </span><a class="url fn n" href="https://www.oxymoronical.com/blog/author/Mossop">Dave Townsend</a></span></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.oxymoronical.com/blog/category/technical/mozilla" rel="category tag">mozilla</a>, <a href="https://www.oxymoronical.com/blog/category/technical" rel="category tag">technical</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.oxymoronical.com/blog/tag/code" rel="tag">code</a>, <a href="https://www.oxymoronical.com/blog/tag/development" rel="tag">development</a>, <a href="https://www.oxymoronical.com/blog/tag/encoding" rel="tag">encoding</a>, <a href="https://www.oxymoronical.com/blog/tag/localization" rel="tag">localization</a></span>			</footer><!-- .entry-footer -->

</article><!-- #post-1942 -->

<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/2019/07/Please-watch-your-character-encodings#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.oxymoronical.com/wp/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1942' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0fa1de84c4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="58"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.oxymoronical.com/blog/2019/03/Bridging-an-internal-LAN-to-a-servers-Docker-containers-over-a-VPN" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Bridging an internal LAN to a server&#8217;s Docker containers over a VPN</span></a></div></div>
	</nav>
		</main><!-- .site-main -->
	</div><!-- .content-area -->


	</div><!-- .site-content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
									<a href="https://wordpress.org/" class="imprint">
				Proudly powered by WordPress			</a>
		</div><!-- .site-info -->
	</footer><!-- .site-footer -->

</div><!-- .site -->

<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201928'></script>
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/js/skip-link-focus-fix.js?ver=20141010'></script>
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-content/themes/twentyfifteen/js/functions.js?ver=20150330'></script>
<script type='text/javascript' src='https://www.oxymoronical.com/wp/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script async="async" type='text/javascript' src='https://www.oxymoronical.com/wp/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201928.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.2',blog:'20978785',post:'1942',tz:'-7',srv:'www.oxymoronical.com'} ]);
	_stq.push([ 'clickTrackerInit', '20978785', '1942' ]);
</script>

</body>
</html>
